03-配置文件管理命令
本章节下载: 03-配置文件管理命令 (172.92 KB)
目 录
1.1.1 display current-configuration
1.1.2 display current-configuration vlan
1.1.3 display saved-configuration
1.1.6 reset saved-configuration
1.1.8 startup saved-configuration
S3600系列以太网交换机支持IRF(Intelligent Resilient Framework,智能弹性架构),用户可以通过如下三种方式访问设备上的文件:
l 访问指定Unit上的文件:输入文件的URL形式以“unit [No.]>flash:/”开头([No.]是交换机的Unit ID)。例如,如果交换机的Unit ID为1,则交换机根路径下的text.txt文件的URL为“unit1>flash:/text.txt”。
l 访问当前Unit上的文件:输入文件的URL形式直接以“flash:/”开头。例如,如果要访问当前本地Unit Flash上根路径下的text.txt文件,则其URL可以写为“flash:/text.txt”。
l 访问当前路径下的文件:直接输入路径名或者文件名。例如,如果要访问当前路径下的text.txt文件,则可以直接使用文件名“text.txt”作为其URL。
【命令】
display current-configuration [ configuration [ configuration-type ] | interface [ interface-type ] [ interface-number ] ] [ by-linenum ] [ | { begin | exclude | include } regular-expression ]
【视图】
任意视图
【参数】
configuration configuration-type:显示非接口配置。如果不指定configuration-type,则显示所有的非接口配置;如果指定configuration-type,则显示指定功能的配置。configuration-type的取值与用户当前已配置的功能有关,例如:
l acl-adv:表示高级访问控制列表的配置。
l acl-basic:表示基本访问控制列表的配置。
l acl-ethernetframe:表示二层访问控制列表的配置。
l acl-user:表示用户自定义访问控制列表的配置。
l isp:表示网络服务提供商的配置。
l radius-template:表示RADIUS模板类型的配置。
l system:表示系统配置。
l user-interface:表示用户界面的配置。
interface interface-type interface-number:显示接口的配置。interface-type为接口类型,可以是Aux、Ethernet、GigabitEthernet、LoopBack、NULL、Vlan-interface。
interface-number为接口编号。
by-linenum:以带有行编号的形式显示配置信息。
|:使用正则表达式过滤显示的配置,用户通过指定正则表达式,就可以迅速定位、查找所需的信息。
regular-expression:正则表达式,区分大小写。它支持多种匹配规则:
l begin:显示特定行及其以后的所有行,该特定行必须包含指定正则表达式。
l exclude:显示不包含指定正则表达式的所有行。
l include:显示只包含指定正则表达式的所有行。
正则表达式还支持多种特殊字符,特殊字符的匹配规则如表1-1所示。
特殊字符 |
含义 |
使用说明 |
^ |
行首匹配符,后面的字符串只能出现在每行的开始 |
正规表达式“^user”表示与出现在行首的字符串“user”匹配,不能匹配以“Auser”开始的行 |
$ |
行尾匹配符,后面的字符串只能出现在每行的末尾 |
正规表达式“user$”表示与出现在行尾的字符串“user”匹配,不能匹配以“userA”结尾的行 |
. |
句点,通配符,匹配任何一个字符,包括空格 |
无 |
* |
星号,匹配星号前面的字符零次或连续多次 |
zo*能匹配“z”以及“zoo”,但不能匹配“zo” |
+ |
加号,匹配加号前面的字符一次或连续多次 |
zo+能匹配“zo”以及“zoo”,但不能匹配“z” |
- |
连接符,用于连接两个数值或字母(小的在前,大的在后),与“[ ]”符号连用表示一个范围 |
如:从1到9表示为1-9(包括1和9);从a到h表示为a-h(包括a和h) |
[ ] |
表示字符选择范围 |
如:[1-36A]表示只可匹配单个字符1、2、3、6、A中的某一个 |
( ) |
表示一组字符,一般与“+”或“*”等符号一起使用 |
如:(123A)表示字符串123A;408(12)+可以匹配40812或408121212等字符串,但不能匹配408,即12可连续出现且至少出现一次 |
【描述】
display current-configuration命令用来显示交换机当前的配置。
当用户完成一组配置之后,需要验证配置是否生效,则可以执行display current-configuration命令来查看当前生效的参数。
需要注意的是:
l 如果当前配置的参数与缺省参数相同,则不予显示;
l 对于某些参数,虽然用户已经配置,但如果这些参数对应的功能没有生效,则不予显示。
相关配置可参考命令save、reset saved-configuration和display saved-configuration。
【举例】
# 显示当前以太网交换机所有接口的配置信息。
<Sysname> display current-configuration interface
#
interface Vlan-interface1
ip address 192.168.0.36 255.255.255.0
igmp enable
#
interface Vlan-interface20
ip address 10.10.10.10 255.255.255.0
#
interface Aux1/0/0
#
interface Ethernet1/0/1
#
interface Ethernet1/0/2
port monitor-link group 3 uplink
#
interface Ethernet1/0/3
port monitor-link group 3 downlink
port access vlan 1040
#
interface Ethernet1/0/4
port monitor-link group 3 downlink
#
interface Ethernet1/0/5
#
interface Ethernet1/0/6
#
interface Ethernet1/0/7
#
interface Ethernet1/0/8
#
interface Ethernet1/0/9
#
interface Ethernet1/0/10
#
interface Ethernet1/0/11
#
interface Ethernet1/0/12
port access vlan 20
dhcp-snooping trust
arp detection trust
#
interface Ethernet1/0/13
port access vlan 20
arp detection trust
#
interface Ethernet1/0/14
port access vlan 20
#
interface Ethernet1/0/15
#
interface Ethernet1/0/16
#
interface Ethernet1/0/17
#
interface Ethernet1/0/18
#
interface Ethernet1/0/19
#
interface Ethernet1/0/20
#
interface Ethernet1/0/21
#
interface Ethernet1/0/22
#
interface Ethernet1/0/23
#
interface Ethernet1/0/24
#
interface GigabitEthernet1/1/1
priority trust
#
interface GigabitEthernet1/1/2
priority trust
#
interface GigabitEthernet1/1/3
#
interface GigabitEthernet1/1/4
#
interface NULL0
#
interface LoopBack0
#
return
# 查看配置信息中包含字符串“10*”的行,“*”表示它前面的“0”可以出现零次或连续多次。
<Sysname> display current-configuration | include 10*
vlan 1
interface Vlan-interface1
ip address 192.168.0.36 255.255.255.0
interface Aux1/0/0
interface Ethernet1/0/1
interface Ethernet1/0/2
interface Ethernet1/0/3
port hybrid vlan 1 3 untagged
port hybrid protocol-vlan vlan 3 1
interface Ethernet1/0/4
mirroring-group 1 monitor-port
interface Ethernet1/0/5
port trunk permit vlan 1 25
interface Ethernet1/0/6
interface Ethernet1/0/7
interface Ethernet1/0/8
interface Ethernet1/0/9
interface Ethernet1/0/10
interface Ethernet1/0/11
interface Ethernet1/0/12
interface Ethernet1/0/13
interface Ethernet1/0/14
interface Ethernet1/0/15
interface Ethernet1/0/16
interface Ethernet1/0/17
interface Ethernet1/0/18
interface Ethernet1/0/19
interface Ethernet1/0/20
interface Ethernet1/0/21
interface Ethernet1/0/22
interface Ethernet1/0/23
interface Ethernet1/0/24
interface GigabitEthernet1/1/1
interface GigabitEthernet1/1/2
interface GigabitEthernet1/1/3
interface GigabitEthernet1/1/4
route-policy song permit node 1
set authentication password simple 1
# 查看包含“user”且以“user”为行首字符串的配置信息。
<Sysname> display current-configuration | include ^user
user-interface aux 0 7
user-interface vty 0 4
【命令】
display current-configuration vlan [ vlan-id ] [ by-linenum ]
【视图】
任意视图
【参数】
vlan vlan-id:VLAN编号,取值范围为1~4094。
by-linenum:以带有行编号的形式显示配置信息。
【描述】
display current-configuration vlan命令用来显示交换机当前VLAN的配置信息。
如果不指定vlan-id参数,则显示交换机当前所有VLAN的配置信息。
如果存在连续编号的VLAN且这些VLAN无任何配置,在显示VLAN配置信息时,交换机将使用vlan-id to vlan-id的形式把连续的空配置VLAN合并。
相关配置可参考命令save,reset saved-configuration,display saved-configuration。
【举例】
# 显示当前以太网交换机中所有VLAN的配置信息。
<Sysname> display current-configuration vlan
#
vlan 1
#
vlan 5 to 69
#
vlan 70
description Vlan 70
#
vlan 71 to 100
#
return
【命令】
display saved-configuration [ unit unit-id ] [ by-linenum ]
【视图】
任意视图
【参数】
unit unit-id:交换机的Unit ID,通过此参数可查看指定Unit上的起始配置文件。
by-linenum:以带有行编号的形式显示配置信息。
【描述】
display saved-configuration命令用来显示交换机的起始配置文件。
需要注意的是:
l 如果交换机启动时没有使用配置文件,即执行display startup命令后显示的当前启动文件为空,那么执行display saved-configuration命令时系统将提示配置文件不存在;
l 如果交换机启动后用户进行过保存配置操作,则执行display saved-configuration命令时将显示最后保存在配置文件中的信息。
相关配置可参考命令save,reset saved-configuration,display current-configuration。
【举例】
# 显示当前以太网交换机的起始配置文件。
<Sysname> display saved-configuration
#
sysname Sysname
#
gvrp
#
MAC-authentication
#
vlan 1
#
interface Vlan-interface1
ip address 192.168.0.36 255.255.255.0
#LOCCFG. MUST NOT DELETE
#
interface Aux1/0/0
#
interface Ethernet1/0/1
priority 7
webcache address 1.1.1.1 mac 0000-0000-0001 vlan 1
traffic-limit inbound ip-group 3001 rule 1 640 exceed remark-dscp 4
traffic-priority inbound ip-group 2000 rule 0 dscp ef
line-rate inbound 128
#
interface Ethernet1/0/2
voice vlan enable
#
interface Ethernet1/0/3
port link-type hybrid
port hybrid vlan 1 3 untagged
voice vlan enable
port hybrid protocol-vlan vlan 3 1
port hybrid protocol-vlan vlan 3 2
#
interface Ethernet1/0/4
mirroring-group 1 monitor-port
#
interface Ethernet1/0/5
port link-type trunk
port trunk permit vlan 1 25
#
interface Ethernet1/0/6
#
interface Ethernet1/0/7
#
interface Ethernet1/0/8
#
interface Ethernet1/0/9
voice vlan enable
#
interface Ethernet1/0/10
port link-type hybrid
port hybrid vlan 1 3 to 4 untagged
port hybrid protocol-vlan vlan 4 0
lacp enable
#
interface Ethernet1/0/11
#
interface Ethernet1/0/12
#
interface Ethernet1/0/13
#
interface Ethernet1/0/14
#
interface Ethernet1/0/15
#
interface Ethernet1/0/16
#
interface Ethernet1/0/17
#
interface Ethernet1/0/18
#
interface Ethernet1/0/19
#
interface Ethernet1/0/20
#
interface Ethernet1/0/21
#
interface Ethernet1/0/22
#
interface Ethernet1/0/23
#
interface Ethernet1/0/24
#
interface GigabitEthernet1/1/1
#
interface GigabitEthernet1/1/2
#
interface GigabitEthernet1/1/3
#
interface GigabitEthernet1/1/4
#TOPOLOGYCFG. MUST NOT DELETE
#
undo irf-fabric authentication-mode
#GLBCFG. MUST NOT DELETE
#
interface NULL0
#
user-interface aux 0 4
idle-timeout 0 0
user-interface aux 5 7
user-interface vty 0 4
authentication-mode none
user privilege level 3
set authentication password simple 1
#
return
以上信息所列的配置依次为系统配置、逻辑接口配置、物理端口配置、用户界面配置。
【命令】
display startup [ unit unit-id ]
【视图】
任意视图
【参数】
unit unit-id:交换机的Unit ID,通过此参数可查看指定Unit上的启动配置文件信息。
【描述】
display startup命令用来显示交换机的启动配置文件信息。
需要注意的是:
l 如果交换机没有形成Fabric,在执行display startup命令时,无论是否指定unit-id参数,都会显示当前交换机的启动配置文件信息。
l 如果交换机已经形成Fabric,在执行display startup命令时,如果没有指定unit-id参数,将显示Fabric中所有Unit的启动配置文件信息;如果指定unit-id参数,将显示Fabric中特定Unit的启动配置文件信息。
相关配置可参考命令startup saved-configuration。
【举例】
# 交换机没有形成Fabric,显示当前交换机的启动配置文件信息。
<Sysname> display startup
UNIT1:
Current Startup saved-configuration file: flash:/config.cfg
Next main startup saved-configuration file: flash:/config.cfg
Next backup startup saved-configuration file: flash:/backup.cfg
Bootrom-access enable state: enabled
表1-2 display startup命令显示信息描述表
字段 |
描述 |
Current Startup saved-configuration file |
当前启动使用的配置文件 |
Next main startup saved-configuration file |
下一次启动时使用的主用配置文件 |
Next backup startup saved-configuration file |
下一次启动时使用的备用配置文件 |
Bootrom-access enable state |
交换机启动过程中用户是否可以使用自定义密码进入BOOTROM菜单: l enabled为开启状态 l disabled为关闭状态 相关内容请参见“文件系统管理”部分中的startup bootrom-access enable命令 |
display this [ by-linenum ]
任意视图
by-linenum:以带有行编号的形式显示配置信息。
display this命令用来显示当前视图下的运行配置。
当用户在某一视图下完成一组配置之后,需要验证配置是否生效,则可以执行display this命令来查看所在视图下当前生效的配置参数。
需要注意的是:
l 对于已经生效的配置参数如果与缺省工作参数相同,则不显示;
l 对于某些参数,虽然用户已经配置,但如果这些参数对应的功能没有生效,则不予显示;
l 在任意一个用户界面视图或VLAN视图下执行此命令,将会显示所有用户界面或VLAN下生效的配置参数。
相关配置可参考命令save,reset saved-configuration,display saved-configuration,display current-configuration。
# 显示所有用户界面视图下生效的配置参数。
<Sysname> system-view
System View: return to User View with Ctrl+Z.
[Sysname] user-interface aux 0
[Sysname-ui-aux0] display this
#
user-interface aux 0 4
idle-timeout 0 0
user-interface aux 5 7
user-interface vty 0
authentication-mode none
user privilege level 3
set authentication password simple 123
idle-timeout 0 0
user-interface vty 1 4
authentication-mode none
user privilege level 3
set authentication password simple 1
idle-timeout 0 0
#
return
【命令】
reset saved-configuration [ backup | main ]
【视图】
用户视图
【参数】
backup:文件备用属性。
main:文件主用属性。
【描述】
reset saved-configuration命令用来清除交换机的Flash中的配置文件或其属性。
需要注意的是:
l 使用reset saved-configuration [ main ]命令清除配置文件时,对于只有主用属性没有备用属性的配置文件,将删除该文件;对于具有主备用双重属性的配置文件,只删除其主用属性。
l 使用reset saved-configuration backup命令清除配置文件时,对于只有备用属性没有主用属性的配置文件,将删除该文件;对于具有主备用双重属性的配置文件,只删除其备用属性。
在以下几种情况下,用户可能需要清除交换机中的配置文件:
l 在交换机软件升级之后,系统软件和配置文件不匹配。
l 交换机中的配置文件被破坏(常见原因是加载了错误的配置文件)。
l 清除操作会将配置文件从交换机上彻底删除,所以请用户慎用该命令;
l 如果被清除的文件不存在,则执行reset saved-configuration命令时交换机会提示错误信息。
相关配置可参考命令save。
【举例】
# 删除交换机下次启动时的主用配置文件。
<Sysname> reset saved-configuration main
The saved configuration will be erased.
Are you sure?[Y/N]y
Configuration in flash memory is being cleared.
Please wait ...
....
Unit1 reset saved-configuration successfully.
【命令】
save [ cfgfile | [ safely ] [ backup | main ] ]
【视图】
任意视图
【参数】
cfgfile:配置文件的路径名或文件名,取值范围为5~56个字符。
safely:采用安全模式保存配置文件。
backup:文件备用属性。
main:文件主用属性。
【描述】
save命令用来把当前配置保存为交换机的Flash中的配置文件。
在使用本命令保存配置文件时:
l 不指定main或backup参数,则当前配置将被保存到主用配置文件中;
l 如果指定cfgfile参数,且cfgfile文件不存在,则系统会把当前配置保存到新创建的cfgfile文件,该文件既无主用属性也无备用属性;
l 如果指定cfgfile参数,但cfgfile文件已经存在,则系统会把当前配置保存到cfgfile文件,文件的属性由保存前的属性决定;
l 如果不指定cfgfile参数,系统会把当前配置保存到本次启动使用的配置文件中,如果本次是以空配置启动,则会以默认的文件名(config.cfg)保存在Flash的根目录下。
系统提供两种保存当前配置文件的方式:
l 如果不使用safely参数,系统采用快速模式保存配置文件。这种方式保存速度快,但是保存过程中如果出现交换机重启、断电等问题,原有配置文件可能会丢失。
l 如果使用safely参数,系统采用安全模式保存配置文件。这种方式保存速度慢,但即使保存过程中出现交换机重启、断电等问题,原有配置文件仍然会保存在交换机的Flash中,不会丢失。
用户使用save safely命令保存配置文件时,如果在保存过程中出现交换机重启、断电等问题,有如下注意事项:
(1) 如果Flash中有以.cfg为后缀名的配置文件存在,下次启动时交换机会以该配置文件中的内容初始化配置。
(2) 如果Flash中没有以.cfg为后缀名的配置文件存在,又分为两种情况:
l 当仅存在以.cfgbak为后缀名的文件(备份文件,对应原有的配置信息)或仅存在以.cfgtmp为后缀名的文件(临时文件,对应当前的配置信息)时,用户可以使用rename命令将备份文件或临时文件的后缀名修改为.cfg,下次启动时交换机会以该配置文件中的内容初始化配置。
l 当以.cfgbak为后缀名的文件和以.cfgtmp为后缀名的文件同时存在时,用户可根据需要使用rename命令将相应文件的后缀名修改为.cfg,下次启动时交换机会以该配置文件中的内容初始化配置。
关于rename命令的详细介绍请参见“文件系统管理”部分。
l 在电源稳定程度较好的环境中,推荐用户使用快速保存方式保存配置文件;在电源环境恶劣或者远程维护等情况下,推荐用户使用安全模式保存配置文件。
l 交换机形成Fabric后,如果在其中某台交换机上执行save命令,Fabric中的各个Unit将各自保存自己的当前配置文件。
l 配置文件必须以“.cfg”作为文件后缀名。
【举例】
# 保存当前运行的配置到123.cfg中,并将123.cfg作为下次启动时的主用配置文件。
<Sysname> save main
The configuration will be written to the device.
Are you sure?[Y/N]y
Please input the file name(*.cfg)(To leave the existing filename
unchanged press the enter key):123.cfg
Now saving current configuration to the device.
Saving configuration. Please wait...
............
Unit1 save configuration flash:/123.cfg successfully
# 保存当前运行的配置到Unit 1中,配置文件名为234.cfg。
<Sysname> save unit1>flash:/234.cfg
The current configuration will be saved to unit1>flash:/234.cfg [Y/N]:y
Now saving current configuration to the device.
Saving configuration. Please wait...
...........
Unit1 save configuration unit1>flash:/234.cfg successfully
【命令】
startup saved-configuration cfgfile [ backup | main ]
undo startup saved-configuration [ unit unit-id ]
【视图】
用户视图
【参数】
cfgfile:配置文件的路径名或文件名,取值范围为5~56个字符。
backup:文件备用属性。
main:文件主用属性。
unit unit-id:交换机的Unit ID,通过此参数可配置指定Unit下次启动时以空配置启动。
【描述】
startup saved-configuration命令用来配置交换机下次启动时使用的配置文件,该配置文件可以是主用配置文件或备用配置文件。undo startup saved-configuration命令用来设置交换机下次启动时以空配置启动。
需要注意的是:
l 执行startup saved-configuration命令时,如果不指定backup和main参数,将会设置文件的主用属性,即将文件设置为下次启动时使用的主用配置文件。
l 当交换机没有形成Fabric时,执行startup saved-configuration命令将会设置当前交换机在下一次启动时使用的配置文件;当交换机形成Fabric后,执行startup saved-configuration命令将会设置Fabric中所有交换机在下一次启动时使用的配置文件。
l 当交换机形成Fabric后,执行undo startup saved-configuration命令时,如果不指定unit-id参数,将会设置Fabric中所有交换机以空配置启动;如果指定unit-id参数,将会设置Fabric中某个特定的Unit以空配置启动。
配置文件必须以“.cfg”作为文件后缀名,并且存放在交换机的Flash的根目录下。
相关配置可参考命令display startup。
【举例】
# 交换机没有形成Fabric,设置当前交换机在下一次启动时使用的主用配置文件为config.cfg。
<Sysname> startup saved-configuration config.cfg main
Please wait......Done!
# 交换机形成Fabric后,设置Fabric中Unit 1下一次启动时使用的备用配置文件为123.cfg。
<Sysname> startup saved-configuration unit1>flash:/123.cfg backup
Please wait......Done!
不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!